# CVE-2025-71399: Better Auth before 1.4.5 Path Normalization Bypass via rou3


- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 2 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-9fq7-6g6p-g9rm, GHSA-x732-6j76-qmhm

## What is CVE-2025-71399?

CVE-2025-71399 is a high-severity vulnerability in better-auth, published on 2 Aug 2026. 

### Official description

Better Auth relies on better-call, which uses the rou3 router library. In affected versions of rou3, paths are normalized by removing empty segments, so /path, //path, and ///path resolve to the same route. In Better Auth versions prior to 1.4.5 (which bundles the fixed rou3), this can allow attackers to bypass disabledPaths configuration and path-based rate limits by submitting requests with extra slashes in the URL path. The issue does not apply in deployments where the proxy or platform normalizes URLs by collapsing multiple slashes.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-71399?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.4.5 |
| `better-auth` | npm | All versions | 1.4.5 |

## How do I fix CVE-2025-71399?

Upgrade better-auth to 1.4.5 or later.

## Is CVE-2025-71399 being exploited?

There is no known exploitation of CVE-2025-71399 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71399 and fix it if it is affected.

What it is: CVE-2025-71399 is a high-severity vulnerability in better-auth, published on 2 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2025-71399 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.4.5
- better-auth (npm): affected all versions; fixed in 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71399/ (Markdown: https://insights.sbomify.com/CVE-2025-71399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71399
- OSV: https://osv.dev/vulnerability/CVE-2025-71399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71399/
Summaries are generated and may contain mistakes; the official description above is the record.
