# CVE-2025-71400: better-auth passkey before 1.4.0 IDOR via delete-passkey


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 2 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-44ff-3cmc-mgqf, GHSA-4vcf-q4xf-f48m

## What is CVE-2025-71400?

CVE-2025-71400 is a high-severity vulnerability in better-auth passkey, published on 2 Aug 2026. 

### Official description

better-auth passkey versions before 1.4.0 contain an insecure direct object reference vulnerability in the passkey deletion endpoint that allows authenticated users to delete arbitrary passkeys by ID. Attackers with valid sessions can submit crafted requests to the delete-passkey endpoint with enumerated passkey IDs to remove other users' passkeys.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-71400?

2 open source packages ship an affected version, including @better-auth/passkey.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/passkey` | npm | All versions | 1.4.0 |
| `@better-auth/passkey` | npm | All versions | 1.4.0 |

## How do I fix CVE-2025-71400?

Upgrade @better-auth/passkey to 1.4.0 or later.

## Is CVE-2025-71400 being exploited?

There is no known exploitation of CVE-2025-71400 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71400 and fix it if it is affected.

What it is: CVE-2025-71400 is a high-severity vulnerability in better-auth passkey, published on 2 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2025-71400 in the wild and no public exploit code.

Affected packages and fixed versions:
- @better-auth/passkey (npm): affected all versions; fixed in 1.4.0
- @better-auth/passkey (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71400/ (Markdown: https://insights.sbomify.com/CVE-2025-71400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71400
- OSV: https://osv.dev/vulnerability/CVE-2025-71400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71400/
Summaries are generated and may contain mistakes; the official description above is the record.
