# CVE-2025-71401: better-auth before 1.4.2 basePath Modification DoS

> An attacker can cause a denial of service by poisoning the base path if the URL is not explicitly configured, affecting better-auth users.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-569q-mpph-wgww

## What is CVE-2025-71401?

CVE-2025-71401 is a critical denial of service vulnerability in better-auth, published on 2 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

better-auth (npm) before 1.4.2 allows an external request to configure baseURL when it is not otherwise defined (e.g., BETTER_AUTH_URL is unset). An attacker able to make the very first request to the server after startup can poison the router's base path, causing all routes to return 404 for all users (denial of service). The issue is not reachable when baseURL is explicitly configured or on typical managed hosting platforms.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-71401?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.4.2 |
| `better-auth` | npm | All versions | 1.4.2 |

## How do I fix CVE-2025-71401?

Upgrade better-auth to 1.4.2 or later.

## Is CVE-2025-71401 being exploited?

There is no known exploitation of CVE-2025-71401 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71401 and fix it if it is affected.

What it is: CVE-2025-71401 is a critical denial of service vulnerability in better-auth, published on 2 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71401 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.4.2
- better-auth (npm): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71401/ (Markdown: https://insights.sbomify.com/CVE-2025-71401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71401
- OSV: https://osv.dev/vulnerability/CVE-2025-71401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71401/
Summaries are generated and may contain mistakes; the official description above is the record.
