{"answers":{"affected":"2 open source packages ship an affected version, including better-auth.","exploited":"There is no known exploitation of CVE-2025-71402 in the wild and no public exploit code.","fix":"Upgrade better-auth to 1.4.0 or later.","what":"CVE-2025-71402 is a low-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-71402 and fix it if it is affected.\n\nWhat it is: CVE-2025-71402 is a low-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-71402 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- better-auth (npm): affected from 1.3.34; fixed in 1.4.0\n- better-auth (npm): affected from 1.3.34; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71402/ (Markdown: https://insights.sbomify.com/CVE-2025-71402/index.md)","id":"CVE-2025-71402","markdown":"https://insights.sbomify.com/CVE-2025-71402/index.md","name":"CVE-2025-71402","record":{"aliases":["GHSA-rf63-989x-x4x8","GHSA-wmjr-v86c-m9jj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Authentication library","requires_auth":"high_privilege","summary":"Attackers can forge multi-session cookies to delete arbitrary user sessions, causing denial of service and bypassing authentication controls in better-auth.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"better-auth versions greater than 1.3.34 and before 1.4.0 contain a vulnerability in the multi-session plugin's /sign-out after-hook, which trusts raw multi-session cookies and forwards extracted values to internalAdapter.deleteSessions without verifying the cookie signature (e.g., via getSignedCookie). An attacker can supply a forged _multi-* cookie to trigger deletion of arbitrary session tokens.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"better-auth before 1.4.0 Session Revocation via Forged Cookie","id":"CVE-2025-71402","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"better-auth before 1.1.20 Open Redirect via trustedOrigins Bypass","id":"CVE-2025-71403"},"packages":[{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["1.3.34"],"last_affected":[],"package":"better-auth","purl":null,"source":"GHSA-wmjr-v86c-m9jj"},{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["1.3.34"],"last_affected":[],"package":"better-auth","purl":"pkg:npm/better-auth","source":"GHSA-wmjr-v86c-m9jj"}],"prev":{"headline":"better-auth before 1.4.2 basePath Modification DoS","id":"CVE-2025-71401"},"products":["better-auth"],"published":"2026-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-03","vendors":["better-auth"]},"summary":"Attackers can forge multi-session cookies to delete arbitrary user sessions, causing denial of service and bypassing authentication controls in better-auth.","url":"https://insights.sbomify.com/CVE-2025-71402/"}