# CVE-2025-71402: better-auth before 1.4.0 Session Revocation via Forged Cookie

> Attackers can forge multi-session cookies to delete arbitrary user sessions, causing denial of service and bypassing authentication controls in better-auth.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-rf63-989x-x4x8, GHSA-wmjr-v86c-m9jj

## What is CVE-2025-71402?

CVE-2025-71402 is a low-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

better-auth versions greater than 1.3.34 and before 1.4.0 contain a vulnerability in the multi-session plugin's /sign-out after-hook, which trusts raw multi-session cookies and forwards extracted values to internalAdapter.deleteSessions without verifying the cookie signature (e.g., via getSignedCookie). An attacker can supply a forged _multi-* cookie to trigger deletion of arbitrary session tokens.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-71402?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | From 1.3.34 | 1.4.0 |
| `better-auth` | npm | From 1.3.34 | 1.4.0 |

## How do I fix CVE-2025-71402?

Upgrade better-auth to 1.4.0 or later.

## Is CVE-2025-71402 being exploited?

There is no known exploitation of CVE-2025-71402 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71402 and fix it if it is affected.

What it is: CVE-2025-71402 is a low-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-71402 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected from 1.3.34; fixed in 1.4.0
- better-auth (npm): affected from 1.3.34; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71402/ (Markdown: https://insights.sbomify.com/CVE-2025-71402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71402
- OSV: https://osv.dev/vulnerability/CVE-2025-71402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71402/
Summaries are generated and may contain mistakes; the official description above is the record.
