# CVE-2025-71403: better-auth before 1.1.20 Open Redirect via trustedOrigins Bypass

> Attackers can exploit a trustedOrigins validation bypass to perform open redirects, potentially stealing tokens and taking over user accounts.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-g2jv-pgqw-qxhv, GHSA-vp58-j275-797x

## What is CVE-2025-71403?

CVE-2025-71403 is a high-severity vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

better-auth versions before 1.1.20 contain a bypass vulnerability in trustedOrigins validation logic affecting absolute URLs and wildcard domains. Attackers can construct malicious callbackURL parameters that pass origin checks and trigger open redirects to steal sensitive tokens for account takeover.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-71403?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.1.21 |
| `better-auth` | npm | All versions | 1.1.21 |

## How do I fix CVE-2025-71403?

Upgrade better-auth to 1.1.21 or later.

## Is CVE-2025-71403 being exploited?

There is no known exploitation of CVE-2025-71403 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71403 and fix it if it is affected.

What it is: CVE-2025-71403 is a high-severity vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-71403 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.1.21
- better-auth (npm): affected all versions; fixed in 1.1.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71403/ (Markdown: https://insights.sbomify.com/CVE-2025-71403/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71403
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71403
- OSV: https://osv.dev/vulnerability/CVE-2025-71403

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71403/
Summaries are generated and may contain mistakes; the official description above is the record.
