CVE-2025-71404 better-auth before 1.1.16 Reflected XSS via error parameter

Medium 5.1 Published Updated

Reflected XSS in better-auth allows attackers to execute arbitrary JavaScript in user browsers via a crafted error parameter URL.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-71404?

CVE-2025-71404 is a medium-severity cross-site scripting vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

Weakness: CWE-79

Which versions are affected by CVE-2025-71404?

2 open source packages ship an affected version, including better-auth.

PackageAffectedFixed in
better-auth npmFrom 0.0.21.1.16
better-auth npmFrom 0.0.21.1.16

How do I fix CVE-2025-71404?

Upgrade better-auth to 1.1.16 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-71404 being exploited?

There is no known exploitation of CVE-2025-71404 in the wild and no public exploit code.

Sources

Also known as GHSA-9x4v-xfq5-m8x5, GHSA-ch2q-47vm-cxgf.

Is CVE-2025-71404 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free