{"answers":{"affected":"2 open source packages ship an affected version, including better-auth.","exploited":"There is no known exploitation of CVE-2025-71404 in the wild and no public exploit code.","fix":"Upgrade better-auth to 1.1.16 or later.","what":"CVE-2025-71404 is a medium-severity cross-site scripting vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-71404 and fix it if it is affected.\n\nWhat it is: CVE-2025-71404 is a medium-severity cross-site scripting vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-71404 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- better-auth (npm): affected from 0.0.2; fixed in 1.1.16\n- better-auth (npm): affected from 0.0.2; fixed in 1.1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71404/ (Markdown: https://insights.sbomify.com/CVE-2025-71404/index.md)","id":"CVE-2025-71404","markdown":"https://insights.sbomify.com/CVE-2025-71404/index.md","name":"CVE-2025-71404","record":{"aliases":["GHSA-9x4v-xfq5-m8x5","GHSA-ch2q-47vm-cxgf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Authentication library","requires_auth":"none","summary":"Reflected XSS in better-auth allows attackers to execute arbitrary JavaScript in user browsers via a crafted error parameter URL.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"better-auth before 1.1.16 Reflected XSS via error parameter","id":"CVE-2025-71404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"go-chi chi before v5.2.2 Open Redirect via RedirectSlashes","id":"CVE-2025-71405"},"packages":[{"ecosystem":"npm","fixed":["1.1.16"],"introduced":["0.0.2"],"last_affected":[],"package":"better-auth","purl":null,"source":"GHSA-9x4v-xfq5-m8x5"},{"ecosystem":"npm","fixed":["1.1.16"],"introduced":["0.0.2"],"last_affected":[],"package":"better-auth","purl":"pkg:npm/better-auth","source":"GHSA-9x4v-xfq5-m8x5"}],"prev":{"headline":"better-auth before 1.1.20 Open Redirect via trustedOrigins Bypass","id":"CVE-2025-71403"},"products":["better-auth"],"published":"2026-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-03","vendors":["better-auth"]},"summary":"Reflected XSS in better-auth allows attackers to execute arbitrary JavaScript in user browsers via a crafted error parameter URL.","url":"https://insights.sbomify.com/CVE-2025-71404/"}