# CVE-2025-71404: better-auth before 1.1.16 Reflected XSS via error parameter

> Reflected XSS in better-auth allows attackers to execute arbitrary JavaScript in user browsers via a crafted error parameter URL.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-9x4v-xfq5-m8x5, GHSA-ch2q-47vm-cxgf

## What is CVE-2025-71404?

CVE-2025-71404 is a medium-severity cross-site scripting vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-71404?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | From 0.0.2 | 1.1.16 |
| `better-auth` | npm | From 0.0.2 | 1.1.16 |

## How do I fix CVE-2025-71404?

Upgrade better-auth to 1.1.16 or later.

## Is CVE-2025-71404 being exploited?

There is no known exploitation of CVE-2025-71404 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71404 and fix it if it is affected.

What it is: CVE-2025-71404 is a medium-severity cross-site scripting vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-71404 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected from 0.0.2; fixed in 1.1.16
- better-auth (npm): affected from 0.0.2; fixed in 1.1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71404/ (Markdown: https://insights.sbomify.com/CVE-2025-71404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71404
- OSV: https://osv.dev/vulnerability/CVE-2025-71404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71404/
Summaries are generated and may contain mistakes; the official description above is the record.
