# CVE-2025-71408: NLTK < 3.9.3 Eval Injection via collocations.py Command-Line Arguments

> Attackers can execute arbitrary Python code by controlling command-line arguments passed to the NLTK collocations module.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2025-71408, ECHO-42f0-e2fb-b0d3, GHSA-848c-c2cx-j7qx, PYSEC-2026-3657, UBUNTU-CVE-2025-71408

## What is CVE-2025-71408?

CVE-2025-71408 is a high-severity code injection vulnerability in ntlk, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NLTK (Natural Language Toolkit) before version 3.9.3 contains an eval injection vulnerability in the nltk.collocations module that allows an attacker who controls command-line arguments to execute arbitrary Python code. When collocations.py is invoked directly, the __main__ block passes command-line arguments directly to eval() as suffixes of BigramAssocMeasures without allowlist validation or sanitization, enabling an attacker to supply a Python expression that escapes the intended attribute lookup and executes arbitrary code including OS commands via the os module.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2025-71408?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.9.3 |
| `nltk` | PyPI | All versions | 3.9.3 |
| `nltk` | PyPI | All versions | 3.9.3 |

Products: Nltk Nltk.

## How do I fix CVE-2025-71408?

Upgrade nltk to 3.9.3 or later.

## Is CVE-2025-71408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71408 exists.

## Other vulnerabilities in ntlk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71408 and fix it if it is affected.

What it is: CVE-2025-71408 is a high-severity code injection vulnerability in ntlk, published on 24 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-71408 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.9.3
- nltk (PyPI): affected all versions; fixed in 3.9.3
- nltk (PyPI): affected all versions; fixed in 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71408/ (Markdown: https://insights.sbomify.com/CVE-2025-71408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71408
- OSV: https://osv.dev/vulnerability/CVE-2025-71408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71408/
Summaries are generated and may contain mistakes; the official description above is the record.
