{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2025-71418 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 5.25.2 or later.","what":"CVE-2025-71418 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-71418 and fix it if it is affected.\n\nWhat it is: CVE-2025-71418 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-71418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.25.2\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.25.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-71418/ (Markdown: https://insights.sbomify.com/CVE-2025-71418/index.md)","id":"CVE-2025-71418","markdown":"https://insights.sbomify.com/CVE-2025-71418/index.md","name":"CVE-2025-71418","record":{"aliases":["GHSA-3rp9-crcm-7w78","GHSA-g274-c6jj-h78p"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"none","summary":"Attackers can cause denial of service by sending crafted packets with excessive delimiters to consume server resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"PocketMine-MP versions before 5.25.2 fail to limit the explode() function in packet parsing, allowing malicious clients to waste server resources. Attackers can send crafted packets with excessive delimiters to consume CPU and memory through sign editing, JWT parsing, and command parsing endpoints.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 5.25.2 Denial of Service via explode","id":"CVE-2025-71418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"UVdesk core-framework before 1.1.7 Stored XSS via SwiftMailer","id":"CVE-2025-71419"},"packages":[{"ecosystem":"Packagist","fixed":["5.25.2"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-g274-c6jj-h78p"},{"ecosystem":"Packagist","fixed":["5.25.2"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-g274-c6jj-h78p"}],"prev":{"headline":"PocketMine-MP before 5.32.1 Denial of Service via ResourcePackClientResponsePacket","id":"CVE-2025-71417"},"products":["PocketMine-MP"],"published":"2026-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can cause denial of service by sending crafted packets with excessive delimiters to consume server resources.","url":"https://insights.sbomify.com/CVE-2025-71418/"}