CVE-2025-71422 Contrast before 1.12.1 Insecure LUKS2 Persistent Storage
A malicious host can bypass LUKS2 encryption in Contrast secure persistent volumes, allowing plaintext access to confidential data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-71422?
CVE-2025-71422 is a medium-severity vulnerability in edgelesssys contrast, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Contrast is a Kubernetes runtime for confidential containers. In versions before 1.12.1, the secure persistent volume feature is vulnerable to a malicious host supplying a crafted LUKS2 volume to a pod VM. LUKS2 volume metadata is not authenticated and, with cryptsetup versions prior to 2.8.1, a header specifying the null keyslot encryption algorithm (cipher_null-ecb) is accepted without error. Because the Contrast Initializer assumes a device is protected if `cryptsetup open` succeeds with the secret seed, the guest will open the attacker-supplied volume and write secret data in plaintext, or under a volume key known to the attacker, allowing the host to read confidential data that should have been encrypted. Contrast v1.12.1 ships cryptsetup 2.8.1, which disables null ciphers in keyslots when the passphrase is non-empty; v1.13.0 adds detached-header validation in guest memory and integrity protection for secure persistent storage. Contrast persistent volumes were not integrity protected, so integrity impact is not considered.
Weakness: CWE-347
Which versions are affected by CVE-2025-71422?
3 open source packages ship an affected version, including github.com/edgelesssys/contrast.
| Package | Affected | Fixed in |
|---|---|---|
github.com/edgelesssys/contrast Go | All versions | 1.12.1 |
github.com/edgelesssys/contrast Go | All versions | 1.12.1 |
github.com/edgelesssys/contrast Go | All versions | 1.12.1 |
How do I fix CVE-2025-71422?
Upgrade github.com/edgelesssys/contrast to 1.12.1 or later.
Is CVE-2025-71422 being exploited?
There is no known exploitation of CVE-2025-71422 in the wild and no public exploit code.
Sources
Also known as GHSA-3g67-j5vf-vm4v, GHSA-f5p4-p5q5-jv3h, GO-2025-4078.