# CVE-2025-71423: Edgelesssys Contrast before 1.12.2 Workload Secrets Information Disclosure

> Attackers with pod log access can read workload secrets from logs, compromising encrypted storage and Vault integrations in Edgeless Systems Contrast.

- **Severity:** High 8.5 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-8rwq-r56x-hx8f, GHSA-vxg3-w9rv-rhr2, GO-2025-3920

## What is CVE-2025-71423?

CVE-2025-71423 is a high-severity vulnerability in edgelesssys contrast, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Edgelesssys Contrast is a confidential-computing runtime for Kubernetes. In versions 1.9.0 before 1.12.2, the initializer logs the full NewMeshCert response — which contains the workload secret — to standard output at INFO level. As a result, workload secrets are exposed to any Kubernetes user with get or list permission on pods/logs. Because workload secrets are used for encrypted storage and Vault integration, those must also be considered compromised. This is a regression of GHSA-h5f8-crrq-4pw8.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-71423?

3 open source packages ship an affected version, including github.com/edgelesssys/contrast.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/edgelesssys/contrast` | Go | From 1.9.0 | 1.12.2 |
| `github.com/edgelesssys/contrast` | Go | From 1.9.0 | 1.12.2 |
| `github.com/edgelesssys/contrast` | Go | From 1.9.0 | 1.12.2 |

## How do I fix CVE-2025-71423?

Upgrade github.com/edgelesssys/contrast to 1.12.2 or later.

## Is CVE-2025-71423 being exploited?

There is no known exploitation of CVE-2025-71423 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71423 and fix it if it is affected.

What it is: CVE-2025-71423 is a high-severity vulnerability in edgelesssys contrast, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71423 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/edgelesssys/contrast (Go): affected from 1.9.0; fixed in 1.12.2
- github.com/edgelesssys/contrast (Go): affected from 1.9.0; fixed in 1.12.2
- github.com/edgelesssys/contrast (Go): affected from 1.9.0; fixed in 1.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71423/ (Markdown: https://insights.sbomify.com/CVE-2025-71423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71423
- OSV: https://osv.dev/vulnerability/CVE-2025-71423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71423/
Summaries are generated and may contain mistakes; the official description above is the record.
