# CVE-2025-71424: Edgeless Systems Contrast before 1.9.1 Insecure Volume Mount

> Attackers can write arbitrary files inside confidential containers via insecure volume mounts on bare-metal deployments, compromising application integrity.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4585-2273-g8cw, GHSA-phhq-63jg-fp7r, GO-2025-3807

## What is CVE-2025-71424?

CVE-2025-71424 is a medium-severity path traversal vulnerability in edgelesssys contrast, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Contrast, Edgeless Systems' runtime for confidential containers on Kubernetes, is affected in versions up to and including 1.9.0. The VOLUME directive in a Dockerfile (config.volumes in the OCI image configuration) is only a hint and is not handled specially by Kubernetes, but containerd adds a mount point for it when Kubernetes sets none, requiring the runtime to be able to push arbitrary data to the Kata agent. As a result, on bare-metal Contrast deployments (AKS deployments are not affected) that run an image declaring at least one VOLUME for which no Kubernetes mount exists at that path, the untrusted host can write arbitrary file trees below that mount point inside the confidential container, compromising the integrity of a directory that is typically important to the application's core functionality. Version 1.9.1 fixes the issue by disallowing this configuration in `contrast generate`.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2025-71424?

3 open source packages ship an affected version, including github.com/edgelesssys/contrast.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/edgelesssys/contrast` | Go | All versions | 1.9.1 |
| `github.com/edgelesssys/contrast` | Go | All versions | 1.9.1 |
| `github.com/edgelesssys/contrast` | Go | All versions | 1.9.1 |

## How do I fix CVE-2025-71424?

Upgrade github.com/edgelesssys/contrast to 1.9.1 or later.

## Is CVE-2025-71424 being exploited?

There is no known exploitation of CVE-2025-71424 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71424 and fix it if it is affected.

What it is: CVE-2025-71424 is a medium-severity path traversal vulnerability in edgelesssys contrast, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71424 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/edgelesssys/contrast (Go): affected all versions; fixed in 1.9.1
- github.com/edgelesssys/contrast (Go): affected all versions; fixed in 1.9.1
- github.com/edgelesssys/contrast (Go): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71424/ (Markdown: https://insights.sbomify.com/CVE-2025-71424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71424
- OSV: https://osv.dev/vulnerability/CVE-2025-71424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71424/
Summaries are generated and may contain mistakes; the official description above is the record.
