# CVE-2025-71435: Coder before 2.23.0 Session Expiration Bypass via OIDC Without Refresh Token

> Authenticated users can retain indefinite access after OIDC token expiry by extending APIKey cookies, bypassing session expiration controls.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-3rw9-wmc8-8948, GHSA-hpmf-3824-qwg6, GO-2025-3921

## What is CVE-2025-71435?

CVE-2025-71435 is a low-severity authentication bypass vulnerability in coder, published on 17 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Coder before 2.23.0 contains a session expiration bypass vulnerability that allows authenticated users to retain access after OIDC token expiry when no refresh token is issued. Users can keep their APIKey cookie active through regular use, extending it every 24 hours to access Coder indefinitely after losing OIDC authorization.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-71435?

4 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | All versions | 2.23.0 |
| `github.com/coder/coder/v2` | Go | All versions | 2.23.0 |
| `github.com/coder/coder/v2` | Go | All versions | 2.23.0 |
| `github.com/coder/coder` | Go | All versions | None |

## How do I fix CVE-2025-71435?

Upgrade github.com/coder/coder/v2 to 2.23.0 or later.

## Is CVE-2025-71435 being exploited?

There is no known exploitation of CVE-2025-71435 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-71435 and fix it if it is affected.

What it is: CVE-2025-71435 is a low-severity authentication bypass vulnerability in coder, published on 17 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-71435 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.23.0
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.23.0
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.23.0
- github.com/coder/coder (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-71435/ (Markdown: https://insights.sbomify.com/CVE-2025-71435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-71435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-71435
- OSV: https://osv.dev/vulnerability/CVE-2025-71435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-71435/
Summaries are generated and may contain mistakes; the official description above is the record.
