# CVE-2025-7326: EOL ASP.NET Core Elevation of Privilege Vulnerability

> Weak authentication in End-of-Life ASP.NET Core allows unauthorized attackers to elevate privileges over the network.

- **Severity:** High 7.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** BIT-aspnet-core-2025-7326, BIT-dotnet-2025-7326, BIT-dotnet-sdk-2025-7326, GHSA-jqfh-6jjg-67xg

## What is CVE-2025-7326?

CVE-2025-7326 is a high-severity authentication bypass vulnerability in Microsoft ASP.NET Core 6.0, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Weak authentication in EOL ASP.NET Core allows an unauthorized attacker to elevate privileges over a network.

NOTE: This CVE affects only End Of Life (EOL) software components. The vendor, Microsoft, has indicated there will be no future updates nor support provided upon inquiry.

Weakness: CWE-1390 (Weak Authentication)

## Which versions are affected by CVE-2025-7326?

3 open source packages ship an affected version, including aspnet-core, dotnet and dotnet-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aspnet-core` | Bitnami | From 6.0.0 | 8.0.1 |
| `dotnet` | Bitnami | From 6.0.0 | 8.0.1 |
| `dotnet-sdk` | Bitnami | From 6.0.0 | 6.0.418 |

## How do I fix CVE-2025-7326?

Upgrade aspnet-core to 8.0.1 or later.

## Is CVE-2025-7326 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7326 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7326 and fix it if it is affected.

What it is: CVE-2025-7326 is a high-severity authentication bypass vulnerability in Microsoft ASP.NET Core 6.0, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7326 exists.

Affected packages and fixed versions:
- aspnet-core (Bitnami): affected from 6.0.0; fixed in 8.0.1
- dotnet (Bitnami): affected from 6.0.0; fixed in 8.0.1
- dotnet-sdk (Bitnami): affected from 6.0.0; fixed in 6.0.418

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7326/ (Markdown: https://insights.sbomify.com/CVE-2025-7326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7326
- OSV: https://osv.dev/vulnerability/CVE-2025-7326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7326/
Summaries are generated and may contain mistakes; the official description above is the record.
