CVE-2025-7337 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

Authenticated developers can cause persistent denial of service for all users by uploading large files, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-7337?

CVE-2025-7337 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.8 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed an authenticated user with Developer-level access to cause a persistent denial of service affecting all users on a GitLab instance by uploading large files.

Weakness: CWE-770

Which versions are affected by CVE-2025-7337?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.8.018.1.6, 18.2.6, 18.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-7337?

Upgrade gitlab to a fixed version for your release line: 18.1.6, 18.2.6 or 18.3.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-7337 being exploited?

There is no known exploitation of CVE-2025-7337 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-7337, GHSA-r22x-m5v3-7gmh.

Is CVE-2025-7337 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free