{"answers":{"affected":"2 open source packages ship an affected version, including multer.","exploited":"There is no known exploitation of CVE-2025-7338 in the wild and no public exploit code.","fix":"Upgrade multer to 2.0.2 or later.","what":"CVE-2025-7338 is a high-severity denial of service vulnerability in expressjs multer, published on 17 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-7338 and fix it if it is affected.\n\nWhat it is: CVE-2025-7338 is a high-severity denial of service vulnerability in expressjs multer, published on 17 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-7338 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.2\n- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-7338/ (Markdown: https://insights.sbomify.com/CVE-2025-7338/index.md)","id":"CVE-2025-7338","markdown":"https://insights.sbomify.com/CVE-2025-7338/index.md","name":"CVE-2025-7338","record":{"aliases":["CLSA-2026-1773879511","ECHO-26b0-db10-57a6","GHSA-fjgf-rc76-4x9p","MINI-72x9-592j-8927","ROOT-APP-NPM-CVE-2025-7338"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js multipart library","requires_auth":"none","summary":"An attacker can crash the application process by sending a malformed multipart upload request to the Multer library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-12-04","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-12-04T16:47:17Z","kind":"github_poc","ref":"https://github.com/r2c-CSE/multer-sca-rule-test_cve-2025-7338","stars":0,"title":"Test to validate CVE-2025-7338 https://semgrep.dev/orgs/-/advisories?f=CAAQGRoTCg1jdmUtMjAyNS03MzM4GgAiAA%3D%3D"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Multer vulnerable to Denial of Service via unhandled exception from malformed request","id":"CVE-2025-7338","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"on-headers vulnerable to http response header manipulation","id":"CVE-2025-7339"},"packages":[{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["1.4.4-lts.1"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-fjgf-rc76-4x9p"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["1.4.4-lts.1"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-fjgf-rc76-4x9p"}],"prev":{"headline":"Allocation of Resources Without Limits or Throttling in GitLab","id":"CVE-2025-7337"},"products":["multer"],"published":"2025-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-17","vendors":["expressjs"]},"summary":"An attacker can crash the application process by sending a malformed multipart upload request to the Multer library.","url":"https://insights.sbomify.com/CVE-2025-7338/"}