# CVE-2025-7338: Multer vulnerable to Denial of Service via unhandled exception from malformed request

> An attacker can crash the application process by sending a malformed multipart upload request to the Multer library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2025
- **Updated:** 17 Jul 2025
- **Also known as:** CLSA-2026-1773879511, ECHO-26b0-db10-57a6, GHSA-fjgf-rc76-4x9p, MINI-72x9-592j-8927, ROOT-APP-NPM-CVE-2025-7338

## What is CVE-2025-7338?

CVE-2025-7338 is a high-severity denial of service vulnerability in expressjs multer, published on 17 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-7338?

2 open source packages ship an affected version, including multer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | From 1.4.4-lts.1 | 2.0.2 |
| `multer` | npm | From 1.4.4-lts.1 | 2.0.2 |

## How do I fix CVE-2025-7338?

Upgrade multer to 2.0.2 or later.

## Is CVE-2025-7338 being exploited?

There is no known exploitation of CVE-2025-7338 in the wild and no public exploit code.

Public exploit code:

- Test to validate CVE-2025-7338 https://semgrep.dev/orgs/-/advisories?f=CAAQGRoTCg1jdmUtMjAyNS03MzM4GgAiAA%3D%3D (github_poc): https://github.com/r2c-CSE/multer-sca-rule-test_cve-2025-7338

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7338 and fix it if it is affected.

What it is: CVE-2025-7338 is a high-severity denial of service vulnerability in expressjs multer, published on 17 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-7338 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.2
- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7338/ (Markdown: https://insights.sbomify.com/CVE-2025-7338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7338
- OSV: https://osv.dev/vulnerability/CVE-2025-7338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7338/
Summaries are generated and may contain mistakes; the official description above is the record.
