# CVE-2025-7339: on-headers vulnerable to http response header manipulation

> An attacker can manipulate HTTP response headers by passing an array to writeHead, potentially altering application behavior or security controls.

- **Severity:** Low 3.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2025
- **Updated:** 17 Jul 2025
- **Also known as:** CLEANSTART-2026-DT32496, CLEANSTART-2026-KX85997, CLSA-2026-1774916715, DEBIAN-CVE-2025-7339, GHSA-76c9-3jph-rj3q, MINI-2rrj-rgvv-662x, MINI-7q7c-9j29-58m3, UBUNTU-CVE-2025-7339

## What is CVE-2025-7339?

CVE-2025-7339 is a low-severity vulnerability in jshttp on-headers, published on 17 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions `<1.1.0` may result in response headers being inadvertently modified when an array is passed to `response.writeHead()`. Users should upgrade to version 1.1.0 to receive a patch. Uses are strongly encouraged to upgrade to `1.1.0`, but this issue can be worked around by passing an object to `response.writeHead()` rather than an array.

Weakness: CWE-241 (Improper Handling of Unexpected Data Type)

## Which versions are affected by CVE-2025-7339?

2 open source packages ship an affected version, including on-headers.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `on-headers` | npm | All versions | 1.1.0 |
| `on-headers` | npm | All versions | 1.1.0 |

## How do I fix CVE-2025-7339?

Upgrade on-headers to 1.1.0 or later.

## Is CVE-2025-7339 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7339 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7339 and fix it if it is affected.

What it is: CVE-2025-7339 is a low-severity vulnerability in jshttp on-headers, published on 17 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7339 exists.

Affected packages and fixed versions:
- on-headers (npm): affected all versions; fixed in 1.1.0
- on-headers (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7339/ (Markdown: https://insights.sbomify.com/CVE-2025-7339/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7339
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7339
- OSV: https://osv.dev/vulnerability/CVE-2025-7339

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7339/
Summaries are generated and may contain mistakes; the official description above is the record.
