CVE-2025-7449 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

Authenticated users with specific permissions can cause a denial of service in GitLab via HTTP response processing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-7449?

CVE-2025-7449 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 8.3 before 18.4.5, 18.5 before 18.5.3, and 18.6 before 18.6.1 that could have allowed an authenticated user with specific permissions to cause a denial of service condition through HTTP response processing.

Weakness: CWE-770

Which versions are affected by CVE-2025-7449?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.3.018.4.5, 18.5.3, 18.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-7449?

Upgrade gitlab to a fixed version for your release line: 18.4.5, 18.5.3 or 18.6.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-7449 being exploited?

There is no known exploitation of CVE-2025-7449 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-7449, GHSA-c3cp-7jp9-c872.

Is CVE-2025-7449 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free