# CVE-2025-7575: Zavy86 WikiDocs submit.php image_delete_ajax path traversal

> Remote attackers can exploit path traversal in WikiDocs to read or modify arbitrary files via image deletion functions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Jul 2025
- **Updated:** 14 Jul 2025
- **Also known as:** GHSA-fgmj-gmv8-5cjg

## What is CVE-2025-7575?

CVE-2025-7575 is a medium-severity path traversal vulnerability in Zavy86 WikiDocs, published on 14 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability has been found in Zavy86 WikiDocs up to 1.0.77 and classified as critical. Affected by this vulnerability is the function image_drop_upload_ajax/image_delete_ajax of the file submit.php. The manipulation leads to path traversal. The attack can be launched remotely. Upgrading to version 1.0.78 is able to address this issue. The identifier of the patch is 98ea9ee4a2052c4327f89d2f7688cc1b5749450d. It is recommended to upgrade the affected component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-7575?


## How do I fix CVE-2025-7575?

No fix has been published for CVE-2025-7575 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-7575 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7575 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7575 and fix it if it is affected.

What it is: CVE-2025-7575 is a medium-severity path traversal vulnerability in Zavy86 WikiDocs, published on 14 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7575 exists.

Affected product: Zavy86 WikiDocs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7575/ (Markdown: https://insights.sbomify.com/CVE-2025-7575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7575
- OSV: https://osv.dev/vulnerability/CVE-2025-7575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7575/
Summaries are generated and may contain mistakes; the official description above is the record.
