{"answers":{"affected":"3 open source packages ship an affected version, including llama-index-core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7647 exists.","fix":"Upgrade llama-index-core to 0.13.0 or later.","what":"CVE-2025-7647 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 27 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-7647 and fix it if it is affected.\n\nWhat it is: CVE-2025-7647 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 27 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7647 exists.\n\nAffected packages and fixed versions:\n- llama-index-core (PyPI): affected all versions; fixed in 0.13.0\n- llama-index-core (PyPI): affected all versions; fixed in 0.13.0\n- llama-index-core (PyPI): affected all versions; fixed in 0.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-7647/ (Markdown: https://insights.sbomify.com/CVE-2025-7647/index.md)","id":"CVE-2025-7647","markdown":"https://insights.sbomify.com/CVE-2025-7647/index.md","name":"CVE-2025-7647","record":{"aliases":["GHSA-cr7q-2w66-hjcm","PYSEC-2026-1562"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python LLM library","requires_auth":"low_privilege","summary":"Attackers on multi-user Linux systems can steal models or poison embeddings via insecure temporary file handling in llama_index.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L","version":"3.0"},"cwes":[{"id":"CWE-378","name":"Creation of Temporary File With Insecure Permissions"}],"description":"The llama-index-core package, up to version 0.12.44, contains a vulnerability in the `get_cache_dir()` function where a predictable, hardcoded directory path `/tmp/llama_index` is used on Linux systems without proper security controls. This vulnerability allows attackers on multi-user systems to steal proprietary models, poison cached embeddings, or conduct symlink attacks. The issue affects all Linux deployments where multiple users share the same system. The vulnerability is classified under CWE-379, CWE-377, and CWE-367, indicating insecure temporary file creation and potential race conditions.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Insecure Temporary File Handling in run-llama/llama_index","id":"CVE-2025-7647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Ruven Themes: Shortcodes \u003c= 1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2025-7648"},"packages":[{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":null,"source":"GHSA-cr7q-2w66-hjcm"},{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":"pkg:pypi/llama-index-core","source":"GHSA-cr7q-2w66-hjcm"},{"ecosystem":"PyPI","fixed":["0.13.0"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":"pkg:pypi/llama-index-core","source":"PYSEC-2026-1562"}],"prev":{"headline":"Cross-site scripting in The Plus Addons for Elementor – Addons for Elementor, Page Templates, Widgets, Mega Menu, WooCommerce","id":"CVE-2025-7646"},"products":["run-llama/llama_index"],"published":"2025-09-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-29","vendors":["run-llama"]},"summary":"Attackers on multi-user Linux systems can steal models or poison embeddings via insecure temporary file handling in llama_index.","url":"https://insights.sbomify.com/CVE-2025-7647/"}