# CVE-2025-7647: Insecure Temporary File Handling in run-llama/llama_index

> Attackers on multi-user Linux systems can steal models or poison embeddings via insecure temporary file handling in llama_index.

- **Severity:** High 7.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2025
- **Updated:** 29 Sep 2025
- **Also known as:** GHSA-cr7q-2w66-hjcm, PYSEC-2026-1562

## What is CVE-2025-7647?

CVE-2025-7647 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 27 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The llama-index-core package, up to version 0.12.44, contains a vulnerability in the `get_cache_dir()` function where a predictable, hardcoded directory path `/tmp/llama_index` is used on Linux systems without proper security controls. This vulnerability allows attackers on multi-user systems to steal proprietary models, poison cached embeddings, or conduct symlink attacks. The issue affects all Linux deployments where multiple users share the same system. The vulnerability is classified under CWE-379, CWE-377, and CWE-367, indicating insecure temporary file creation and potential race conditions.

Weakness: CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2025-7647?

3 open source packages ship an affected version, including llama-index-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.13.0 |
| `llama-index-core` | PyPI | All versions | 0.13.0 |
| `llama-index-core` | PyPI | All versions | 0.13.0 |

## How do I fix CVE-2025-7647?

Upgrade llama-index-core to 0.13.0 or later.

## Is CVE-2025-7647 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7647 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7647 and fix it if it is affected.

What it is: CVE-2025-7647 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 27 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-7647 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.13.0
- llama-index-core (PyPI): affected all versions; fixed in 0.13.0
- llama-index-core (PyPI): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7647/ (Markdown: https://insights.sbomify.com/CVE-2025-7647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7647
- OSV: https://osv.dev/vulnerability/CVE-2025-7647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7647/
Summaries are generated and may contain mistakes; the official description above is the record.
