CVE-2025-7659 Origin Validation Error in GitLab

High 8.0 Published Updated

An unauthenticated attacker can steal tokens and access private repositories by exploiting incomplete origin validation in the GitLab Web IDE.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-7659?

CVE-2025-7659 is a high-severity vulnerability in Gitlab Gitlab, published on 11 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that could have allowed an unauthenticated user to steal tokens and access private repositories by abusing incomplete validation in the Web IDE.

Weakness: CWE-346

Which versions are affected by CVE-2025-7659?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.018.6.6, 18.7.4, 18.8.4

Products include Gitlab Gitlab.

How do I fix CVE-2025-7659?

Upgrade gitlab to a fixed version for your release line: 18.6.6, 18.7.4 or 18.8.4.

Is CVE-2025-7659 being exploited?

There is no known exploitation of CVE-2025-7659 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-7659, GHSA-7p7x-r7pv-gq7p, UBUNTU-CVE-2025-7659.

Is CVE-2025-7659 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free