CVE-2025-7691 Privilege Defined With Unsafe Actions in GitLab

Medium 6.5 Published Updated

A developer with specific group management permissions can escalate privileges to gain unauthorized access to additional system capabilities in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-7691?

CVE-2025-7691 is a medium-severity vulnerability in Gitlab Gitlab, published on 26 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A privilege escalation issue has been discovered in GitLab EE affecting all versions from 16.6 prior to 18.2.7, 18.3 prior to 18.3.3, and 18.4 prior to 18.4.1 that could have allowed a developer with specific group management permissions to escalate their privileges and obtain unauthorized access to additional system capabilities.

Weakness: CWE-267

Which versions are affected by CVE-2025-7691?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.6.018.2.7, 18.3.3, 18.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-7691?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

Is CVE-2025-7691 being exploited?

There is no known exploitation of CVE-2025-7691 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-7691, GHSA-38q5-vqf6-27rf.

Is CVE-2025-7691 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free