# CVE-2025-7707: World-Writable NLTK Cache Directory Vulnerability in run-llama/llama_index

> Local attackers can tamper with world-writable NLTK cache files in llama_index, causing denial of service or privilege escalation.

- **Severity:** High 7.1 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-rg9h-vx28-xxp5, PYSEC-2026-1556

## What is CVE-2025-7707?

CVE-2025-7707 is a high-severity vulnerability in run-llama/llama_index, published on 13 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

Weakness: CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2025-7707?

3 open source packages ship an affected version, including llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | All versions | 0.13.0 |
| `llama-index` | PyPI | All versions | 0.13.0 |
| `llama-index` | PyPI | All versions | 0.13.0 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-7707?

Upgrade llama-index to 0.13.0 or later.

## Is CVE-2025-7707 being exploited?

There is no known exploitation of CVE-2025-7707 in the wild and no public exploit code.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7707 and fix it if it is affected.

What it is: CVE-2025-7707 is a high-severity vulnerability in run-llama/llama_index, published on 13 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-7707 in the wild and no public exploit code.

Affected packages and fixed versions:
- llama-index (PyPI): affected all versions; fixed in 0.13.0
- llama-index (PyPI): affected all versions; fixed in 0.13.0
- llama-index (PyPI): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7707/ (Markdown: https://insights.sbomify.com/CVE-2025-7707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7707
- OSV: https://osv.dev/vulnerability/CVE-2025-7707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7707/
Summaries are generated and may contain mistakes; the official description above is the record.
