CVE-2025-7734 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

Attackers can inject malicious content to execute actions on behalf of users in GitLab, requiring an upgrade to secure versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-7734?

CVE-2025-7734 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 14.2 before 18.0.6, 18.1 before 18.1.4 and 18.2 before 18.2.2 that, under certain conditions, could have allowed a successful attacker to execute actions on behalf of users by injecting malicious content.

Weakness: CWE-79

Which versions are affected by CVE-2025-7734?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.2.018.0.6, 18.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-7734?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-7734 being exploited?

There is no known exploitation of CVE-2025-7734 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-7734, GHSA-vp64-6mxr-66qc, MINI-6g35-g292-2rch, MINI-jprw-83vw-cxhc, MINI-qvmc-xvf8-77g8, UBUNTU-CVE-2025-7734.

Is CVE-2025-7734 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free