CVE-2025-7736 Incorrect Authorization in GitLab

Low 3.1 Published Updated

Authenticated attackers can bypass access controls to view private GitLab Pages content via OAuth authentication flaws.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-7736?

CVE-2025-7736 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 15 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.9 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated attacker to bypass access control restrictions and view GitLab Pages content intended only for project members by authenticating through OAuth providers.

Weakness: CWE-863

Which versions are affected by CVE-2025-7736?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.9.018.3.6, 18.4.4, 18.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-7736?

Upgrade gitlab to a fixed version for your release line: 18.3.6, 18.4.4 or 18.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-7736 being exploited?

There is no known exploitation of CVE-2025-7736 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-7736, GHSA-7hhv-h469-wc4q, MINI-24w2-6rcc-rcp6, MINI-29pj-59p8-jg4j, MINI-2rhx-jxvr-mjfw, MINI-3g2g-f7cm-p5j8 and 13 more.

Is CVE-2025-7736 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free