# CVE-2025-7899: Insecure Direct Object Reference in extension "powermail" (powermail)

> Attackers can download arbitrary files from the webserver via insecure direct object reference in the powermail extension.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** GHSA-x769-3cwv-f8hc

## What is CVE-2025-7899?

CVE-2025-7899 is a medium-severity path traversal vulnerability in TYPO3 Extension "powermail", published on 22 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The powermail extension for TYPO3 allows Insecure Direct Object Reference resulting in download of arbitrary files from the webserver. This issue affects powermail version 12.0.0 up to 12.5.2 and version 13.0.0

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-7899?

4 open source packages ship an affected version, including in2code/powermail.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/powermail` | Packagist | From 12.0.0 | 12.5.3 |
| `in2code/powermail` | Packagist | From 12.0.0 | 12.5.3 |
| `in2code/powermail` | Packagist | From 13.0.0 | 13.0.1 |
| `in2code/powermail` | Packagist | From 13.0.0 | 13.0.1 |

## How do I fix CVE-2025-7899?

Upgrade in2code/powermail to a fixed version for your release line: 12.5.3 or 13.0.1.

## Is CVE-2025-7899 being exploited?

There is no known exploitation of CVE-2025-7899 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7899 and fix it if it is affected.

What it is: CVE-2025-7899 is a medium-severity path traversal vulnerability in TYPO3 Extension "powermail", published on 22 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-7899 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/powermail (Packagist): affected from 12.0.0; fixed in 12.5.3
- in2code/powermail (Packagist): affected from 12.0.0; fixed in 12.5.3
- in2code/powermail (Packagist): affected from 13.0.0; fixed in 13.0.1
- in2code/powermail (Packagist): affected from 13.0.0; fixed in 13.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7899/ (Markdown: https://insights.sbomify.com/CVE-2025-7899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7899
- OSV: https://osv.dev/vulnerability/CVE-2025-7899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7899/
Summaries are generated and may contain mistakes; the official description above is the record.
