# CVE-2025-7962: Jakarta Mail vulnerable to SMTP Injection

> Attackers can inject SMTP commands via CRLF characters in Jakarta Mail, potentially altering message delivery or content.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-GU43525, CLEANSTART-2026-LI24140, CLEANSTART-2026-LT00301, CLEANSTART-2026-OE66556, CLEANSTART-2026-PU24283, CLEANSTART-2026-VN01735, CLSA-2026-1791372817, DEBIAN-CVE-2025-7962, ECHO-fb57-1326-0be8, GHSA-9342-92gg-6v29, MINI-337p-94c9-7gvv, MINI-3qp8-wrwq-c3jh, MINI-5pfw-hc94-749f, MINI-83m2-c7r4-g656, MINI-92fg-4wxx-jvq4, MINI-93p9-hxqm-9x76, MINI-9j67-9jqp-vvg4, MINI-cjv7-x8pj-xwq6, MINI-f29j-xqrh-wchx, MINI-ff57-5jcc-3m5w, MINI-hx98-c26f-cf7p, MINI-j3hx-53cj-rvrr, MINI-p4hg-gh5h-7gj3, MINI-pgj7-cjjg-r6f7, MINI-q6xf-hx77-wg5m, MINI-q9gc-39j2-87r4, MINI-r24q-5xxh-3c2q, MINI-wmjc-2m35-jrpr, MINI-wqwm-6g7c-p7jx, OESA-2025-1987, OESA-2025-1988, OESA-2025-1989, OESA-2025-1990, OESA-2025-1991, RHLW-2026-49443da84312bd4d, RHLW-2026-c45d2a64e2c0626e, ROOT-APP-MAVEN-CVE-2025-7962, SUSE-SU-2025:03025-1, UBUNTU-CVE-2025-7962, openSUSE-SU-2025:15378-1, openSUSE-SU-2026:11763-1

## What is CVE-2025-7962?

CVE-2025-7962 is a medium-severity vulnerability in Eclipse Foundation Jakarta Mail, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Jakarta Mail versions prior to 2.0.2 it is possible to perform an SMTP Injection by utilizing the \r and \n UTF-8 characters to separate different messages.

Weakness: CWE-147 (Improper Neutralization of Input Terminators)

## Which versions are affected by CVE-2025-7962?

6 open source packages ship an affected version, including com.sun.mail:jakarta.mail and org.eclipse.angus:smtp. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.sun.mail:jakarta.mail` | Maven | All versions | 1.6.8 |
| `com.sun.mail:jakarta.mail` | Maven | All versions | 1.6.8 |
| `com.sun.mail:jakarta.mail` | Maven | From 2.0.0 | 2.0.2 |
| `com.sun.mail:jakarta.mail` | Maven | From 2.0.0 | 2.0.2 |
| `org.eclipse.angus:smtp` | Maven | All versions | 2.0.4 |
| `org.eclipse.angus:smtp` | Maven | All versions | 2.0.4 |
| `javamail` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.6.2-150200.3.7.1 |
| `javamail` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 1.6.2-150200.3.7.1 |
| `javamail` | openSUSE:Leap 15.6 | All versions | 1.6.2-150200.3.7.1 |
| `ant` | openSUSE:Tumbleweed | All versions | 1.10.18-1.1 |
| `javamail` | openSUSE:Tumbleweed | All versions | 1.6.2-3.1 |

Products: Eclipse Angus Mail, Eclipse Jakarta Mail.

## How do I fix CVE-2025-7962?

Upgrade com.sun.mail:jakarta.mail to a fixed version for your release line: 1.6.8 or 2.0.2.

## Is CVE-2025-7962 being exploited?

There is no known exploitation of CVE-2025-7962 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-7962 and fix it if it is affected.

What it is: CVE-2025-7962 is a medium-severity vulnerability in Eclipse Foundation Jakarta Mail, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-7962 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.sun.mail:jakarta.mail (Maven): affected all versions; fixed in 1.6.8
- com.sun.mail:jakarta.mail (Maven): affected all versions; fixed in 1.6.8
- com.sun.mail:jakarta.mail (Maven): affected from 2.0.0; fixed in 2.0.2
- com.sun.mail:jakarta.mail (Maven): affected from 2.0.0; fixed in 2.0.2
- org.eclipse.angus:smtp (Maven): affected all versions; fixed in 2.0.4
- org.eclipse.angus:smtp (Maven): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-7962/ (Markdown: https://insights.sbomify.com/CVE-2025-7962/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-7962
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-7962
- OSV: https://osv.dev/vulnerability/CVE-2025-7962

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-7962/
Summaries are generated and may contain mistakes; the official description above is the record.
