CVE-2025-8014 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

Unauthenticated attackers can bypass GraphQL query complexity limits to cause resource exhaustion and service disruption in GitLab.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-8014?

CVE-2025-8014 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 27 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Denial of Service issue in GraphQL endpoints in Gitlab EE/CE affecting all versions from 11.10 prior to 18.2.7, 18.3 prior to 18.3.3, and 18.4 prior to 18.4.1 allows unauthenticated users to potentially bypass query complexity limits leading to resource exhaustion and service disruption.

Weakness: CWE-770

Which versions are affected by CVE-2025-8014?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.10.018.2.7, 18.3.3, 18.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-8014?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-8014 being exploited?

There is no known exploitation of CVE-2025-8014 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-8014, GHSA-688v-85ch-v3v6.

Is CVE-2025-8014 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free