# CVE-2025-8077: NeuVector admin account has insecure default password

> Attackers can use the fixed default admin password to gain full control of NeuVector if the password is not changed after deployment.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-8pxw-9c75-6w56, GO-2025-3918

## What is CVE-2025-8077?

CVE-2025-8077 is a critical vulnerability in SUSE neuvector, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability exists in NeuVector versions up to and including 5.4.5, where a fixed string is used as the default password for the built-in `admin` account. If this password is not changed immediately after deployment, any workload with network access within the cluster could use the default credentials to obtain an authentication token. This token can then be used to perform any operation via NeuVector APIs.

Weakness: CWE-1393 (Use of Default Password)

## Which versions are affected by CVE-2025-8077?

3 open source packages ship an affected version, including github.com/neuvector/neuvector.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/neuvector/neuvector` | Go | All versions | None |
| `github.com/neuvector/neuvector` | Go | All versions | 0.0.0-20250825191744-da1a462074c3 |
| `github.com/neuvector/neuvector` | Go | All versions | 0.0.0-20250825191744-da1a462074c3 |

## How do I fix CVE-2025-8077?

Upgrade github.com/neuvector/neuvector to 0.0.0-20250825191744-da1a462074c3 or later.

## Is CVE-2025-8077 being exploited?

There is no known exploitation of CVE-2025-8077 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8077 and fix it if it is affected.

What it is: CVE-2025-8077 is a critical vulnerability in SUSE neuvector, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-8077 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/neuvector/neuvector (Go): affected all versions; no fix listed
- github.com/neuvector/neuvector (Go): affected all versions; fixed in 0.0.0-20250825191744-da1a462074c3
- github.com/neuvector/neuvector (Go): affected all versions; fixed in 0.0.0-20250825191744-da1a462074c3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8077/ (Markdown: https://insights.sbomify.com/CVE-2025-8077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8077
- OSV: https://osv.dev/vulnerability/CVE-2025-8077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8077/
Summaries are generated and may contain mistakes; the official description above is the record.
