# CVE-2025-8082: Vuetify XSS via unsanitized 'titleDateFormat' in 'VDatePicker'

> Attackers can execute arbitrary scripts via unsanitized HTML in Vuetify's VDatePicker title, affecting end-of-life version 2.x.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Dec 2025
- **Updated:** 12 Dec 2025
- **Also known as:** CLSA-2026-1788869743, GHSA-9w3x-85mw-4fwm

## What is CVE-2025-8082?

CVE-2025-8082 is a medium-severity cross-site scripting vulnerability in Vuetify, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper neutralization of the title date in the 'VDatePicker' component in Vuetify, allows unsanitized HTML to be inserted into the page. This can lead to a  Cross-Site Scripting (XSS) https://owasp.org/www-community/attacks/xss  attack. The vulnerability occurs because the 'title-date-format' property of the 'VDatePicker' can accept a user created function and assign its output to the 'innerHTML' property of the title element without sanitization.

This issue affects Vuetify versions greater than or equal to 2.0.0 and less than 3.0.0.

Note:
Version 2.x of Vuetify is End-of-Life and will not receive any updates to address this issue. For more information see  here https://v2.vuetifyjs.com/en/about/eol/ .

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-8082?

2 open source packages ship an affected version, including vuetify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vuetify` | npm | From 2.0.0 | 3.0.0 |
| `vuetify` | npm | From 2.0.0 | 3.0.0 |

## How do I fix CVE-2025-8082?

Upgrade vuetify to 3.0.0 or later.

## Is CVE-2025-8082 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8082 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8082 and fix it if it is affected.

What it is: CVE-2025-8082 is a medium-severity cross-site scripting vulnerability in Vuetify, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8082 exists.

Affected packages and fixed versions:
- vuetify (npm): affected from 2.0.0; fixed in 3.0.0
- vuetify (npm): affected from 2.0.0; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8082/ (Markdown: https://insights.sbomify.com/CVE-2025-8082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8082
- OSV: https://osv.dev/vulnerability/CVE-2025-8082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8082/
Summaries are generated and may contain mistakes; the official description above is the record.
