{"answers":{"affected":"2 open source packages ship an affected version, including linkifyjs.","exploited":"There is no known exploitation of CVE-2025-8101 in the wild and no public exploit code.","fix":"Upgrade linkifyjs to 4.3.2 or later.","what":"CVE-2025-8101 is a high-severity cross-site scripting vulnerability in Linkify, published on 25 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-8101 and fix it if it is affected.\n\nWhat it is: CVE-2025-8101 is a high-severity cross-site scripting vulnerability in Linkify, published on 25 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-8101 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- linkifyjs (npm): affected from 4.3.1; fixed in 4.3.2\n- linkifyjs (npm): affected from 4.3.1; fixed in 4.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8101/ (Markdown: https://insights.sbomify.com/CVE-2025-8101/index.md)","id":"CVE-2025-8101","markdown":"https://insights.sbomify.com/CVE-2025-8101/index.md","name":"CVE-2025-8101","record":{"aliases":["CLSA-2026-1783040464","CLSA-2026-1792864663","CLSA-2026-1793007594","CLSA-2026-1793146498","CLSA-2026-1793152364","CLSA-2026-1793156743","GHSA-95jq-xph2-cx9h","ROOT-APP-NPM-CVE-2025-8101"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript linkify library","requires_auth":"none","summary":"Attackers can inject malicious HTML attributes via prototype pollution in the Linkify library, leading to cross-site scripting attacks.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Fluid Attacks","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') vulnerability in Linkify (linkifyjs) allows XSS Targeting HTML Attributes and Manipulating User-Controlled Variables.This issue affects Linkify: from 4.3.1 before 4.3.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Linkify 4.3.1 - Prototype Pollution \u0026 HTML Attribute Injection (XSS)","id":"CVE-2025-8101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-site request forgery in Easy Digital Downloads – eCommerce Payments and Subscriptions made easy","id":"CVE-2025-8102"},"packages":[{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.3.1"],"last_affected":[],"package":"linkifyjs","purl":null,"source":"GHSA-95jq-xph2-cx9h"},{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.3.1"],"last_affected":[],"package":"linkifyjs","purl":"pkg:npm/linkifyjs","source":"GHSA-95jq-xph2-cx9h"}],"prev":{"headline":"Cross-site scripting in Element Pack – Widgets, Templates \u0026 Addons for Elementor","id":"CVE-2025-8100"},"products":["Linkify"],"published":"2025-07-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-03","vendors":["Linkify"]},"summary":"Attackers can inject malicious HTML attributes via prototype pollution in the Linkify library, leading to cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2025-8101/"}