# CVE-2025-8133: yanyutao0402 ChanCMS gather.js getArticle server-side request forgery

> Remote attackers can exploit a server-side request forgery vulnerability in ChanCMS to access internal resources or bypass security controls.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jul 2025
- **Updated:** 27 Jul 2025
- **Also known as:** GHSA-wxq5-cqj8-p4vx

## What is CVE-2025-8133?

CVE-2025-8133 is a medium-severity server-side request forgery vulnerability in yanyutao0402 ChanCMS, published on 25 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability classified as critical has been found in yanyutao0402 ChanCMS up to 3.1.2. This affects the function getArticle of the file app/modules/api/service/gather.js. The manipulation of the argument targetUrl leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.3 is able to address this issue. The identifier of the patch is 3ef58a50e8b3c427b03c8cf3c9e19a79aa809be6. It is recommended to upgrade the affected component.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-8133?

It affects 1 product.


Products: Chancms Chancms.

## How do I fix CVE-2025-8133?

No fix has been published for CVE-2025-8133 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8133 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8133 exists.

## Other vulnerabilities in yanyutao0402 ChanCMS

- [CVE-2025-65602](https://insights.sbomify.com/CVE-2025-65602/): Code injection in n/a (critical 9.8)
- [CVE-2025-11902](https://insights.sbomify.com/CVE-2025-11902/): yanyutao0402 ChanCMS findField sql injection (medium 5.3)
- [CVE-2025-11903](https://insights.sbomify.com/CVE-2025-11903/): yanyutao0402 ChanCMS update sql injection (medium 5.3)
- [CVE-2025-11904](https://insights.sbomify.com/CVE-2025-11904/): yanyutao0402 ChanCMS hasUse sql injection (medium 5.3)
- [CVE-2025-11905](https://insights.sbomify.com/CVE-2025-11905/): yanyutao0402 ChanCMS gather.js getArticle code injection (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8133 and fix it if it is affected.

What it is: CVE-2025-8133 is a medium-severity server-side request forgery vulnerability in yanyutao0402 ChanCMS, published on 25 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8133 exists.

Affected product: yanyutao0402 ChanCMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8133/ (Markdown: https://insights.sbomify.com/CVE-2025-8133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8133
- OSV: https://osv.dev/vulnerability/CVE-2025-8133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8133/
Summaries are generated and may contain mistakes; the official description above is the record.
