CVE-2025-8228 yanyutao0402 ChanCMS getPages server-side request forgery

Medium 5.3 Published Updated

Remote attackers can exploit a server-side request forgery vulnerability in ChanCMS to access internal resources or bypass security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-8228?

CVE-2025-8228 is a medium-severity server-side request forgery vulnerability in yanyutao0402 ChanCMS, published on 27 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in yanyutao0402 ChanCMS up to 3.1.2. It has been rated as critical. Affected by this issue is the function getPages of the file /cms/collect/getPages. The manipulation of the argument targetUrl leads to server-side request forgery. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.3 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-918

Which versions are affected by CVE-2025-8228?

It affects 1 product.

Products include Chancms Chancms.

How do I fix CVE-2025-8228?

No fix has been published for CVE-2025-8228 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-8228 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8228 exists.

Sources

Also known as GHSA-43hh-wmr7-r7rm.

Is CVE-2025-8228 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free