CVE-2025-8259 Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection
Remote attackers can execute arbitrary OS commands via the xajaxargs parameter in the VaelsysV4 web interface, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-8259?
CVE-2025-8259 is a medium-severity command injection vulnerability in VaelsysV4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was identified in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. Affected by this issue is the function execute_DataObjectProc of the file /grid/vgrid_server.php of the component Web interface. Such manipulation of the argument xajaxargs leads to os command injection. The attack can be executed remotely. The exploit is publicly available and might be used. Upgrading to version 5.1.1 and 5.4.1 can resolve this issue. It is suggested to upgrade the affected component.
Which versions are affected by CVE-2025-8259?
It affects 1 product.
Products include Vaelsys Vaelsys.
How do I fix CVE-2025-8259?
No fix has been published for CVE-2025-8259 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2025-8259 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8259 exists.
Other vulnerabilities in VaelsysV4
Sources
Also known as GHSA-8wmv-6886-5g9j.