{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8259 exists.","fix":"No fix has been published for CVE-2025-8259 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-8259 is a medium-severity command injection vulnerability in VaelsysV4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-8259 and fix it if it is affected.\n\nWhat it is: CVE-2025-8259 is a medium-severity command injection vulnerability in VaelsysV4, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8259 exists.\n\nAffected product: VaelsysV4. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8259/ (Markdown: https://insights.sbomify.com/CVE-2025-8259/index.md)","id":"CVE-2025-8259","markdown":"https://insights.sbomify.com/CVE-2025-8259/index.md","name":"CVE-2025-8259","record":{"aliases":["GHSA-8wmv-6886-5g9j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"VaelsysV4 web interface","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands via the xajaxargs parameter in the VaelsysV4 web interface, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"vaelsys","vendor":"vaelsys"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability was identified in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. Affected by this issue is the function execute_DataObjectProc of the file /grid/vgrid_server.php of the component Web interface. Such manipulation of the argument xajaxargs leads to os command injection. The attack can be executed remotely. The exploit is publicly available and might be used. Upgrading to version 5.1.1 and 5.4.1 can resolve this issue. It is suggested to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection","id":"CVE-2025-8259","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash","id":"CVE-2025-8260"},"packages":[],"prev":{"headline":"Cool Mo Maigcal Number App com.sdmagic.number AndroidManifest.xml improper export of android application components","id":"CVE-2025-8258"},"products":["VaelsysV4"],"published":"2025-07-28","related":[{"cvss_score":6.9,"headline":"Vaelsys HTTP POST Request tree_server.php os command injection","id":"CVE-2026-2952","kev_date_added":null,"published":"2026-02-22"},{"cvss_score":6.9,"headline":"Vaelsys VaelsysV4 User Creation vgrid_server.php improper authorization","id":"CVE-2025-8261","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":2.3,"headline":"Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash","id":"CVE-2025-8260","kev_date_added":null,"published":"2025-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["Vaelsys"]},"summary":"Remote attackers can execute arbitrary OS commands via the xajaxargs parameter in the VaelsysV4 web interface, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-8259/"}