CVE-2025-8260 Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash

Low 2.3 Published Updated

Remote attackers can exploit weak hashing in the web interface to bypass security controls, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-8260?

CVE-2025-8260 is a low-severity vulnerability in VaelsysV4, published on 28 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A security flaw has been discovered in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. This affects an unknown part of the file /grid/vgrid_server.php of the component Web interface. Performing a manipulation of the argument xajaxargs results in use of weak hash. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 5.1.1 and 5.4.1 is able to mitigate this issue. Upgrading the affected component is recommended.

Weakness: CWE-328, CWE-327

Which versions are affected by CVE-2025-8260?

It affects 1 product.

Products include Vaelsys Vaelsys.

How do I fix CVE-2025-8260?

No fix has been published for CVE-2025-8260 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-8260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8260 exists.

Sources

Also known as GHSA-8rhv-2p84-6g62.

Is CVE-2025-8260 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free