{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8260 exists.","fix":"No fix has been published for CVE-2025-8260 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-8260 is a low-severity vulnerability in VaelsysV4, published on 28 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-8260 and fix it if it is affected.\n\nWhat it is: CVE-2025-8260 is a low-severity vulnerability in VaelsysV4, published on 28 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8260 exists.\n\nAffected product: VaelsysV4. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8260/ (Markdown: https://insights.sbomify.com/CVE-2025-8260/index.md)","id":"CVE-2025-8260","markdown":"https://insights.sbomify.com/CVE-2025-8260/index.md","name":"CVE-2025-8260","record":{"aliases":["GHSA-8rhv-2p84-6g62"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"VaelsysV4 web interface","requires_auth":"low_privilege","summary":"Remote attackers can exploit weak hashing in the web interface to bypass security controls, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"vaelsys","vendor":"vaelsys"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-328","name":"Use of Weak Hash"},{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"A security flaw has been discovered in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. This affects an unknown part of the file /grid/vgrid_server.php of the component Web interface. Performing a manipulation of the argument xajaxargs results in use of weak hash. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 5.1.1 and 5.4.1 is able to mitigate this issue. Upgrading the affected component is recommended.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash","id":"CVE-2025-8260","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"Vaelsys VaelsysV4 User Creation vgrid_server.php improper authorization","id":"CVE-2025-8261"},"packages":[],"prev":{"headline":"Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection","id":"CVE-2025-8259"},"products":["VaelsysV4"],"published":"2025-07-28","related":[{"cvss_score":6.9,"headline":"Vaelsys HTTP POST Request tree_server.php os command injection","id":"CVE-2026-2952","kev_date_added":null,"published":"2026-02-22"},{"cvss_score":6.9,"headline":"Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection","id":"CVE-2025-8259","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":6.9,"headline":"Vaelsys VaelsysV4 User Creation vgrid_server.php improper authorization","id":"CVE-2025-8261","kev_date_added":null,"published":"2025-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["Vaelsys"]},"summary":"Remote attackers can exploit weak hashing in the web interface to bypass security controls, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-8260/"}