# CVE-2025-8260: Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash

> Remote attackers can exploit weak hashing in the web interface to bypass security controls, requiring an upgrade to mitigate.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Jul 2025
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-8rhv-2p84-6g62

## What is CVE-2025-8260?

CVE-2025-8260 is a low-severity vulnerability in VaelsysV4, published on 28 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security flaw has been discovered in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. This affects an unknown part of the file /grid/vgrid_server.php of the component Web interface. Performing a manipulation of the argument xajaxargs results in use of weak hash. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 5.1.1 and 5.4.1 is able to mitigate this issue. Upgrading the affected component is recommended.

Weakness: CWE-328 (Use of Weak Hash), CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2025-8260?

It affects 1 product.


Products: Vaelsys Vaelsys.

## How do I fix CVE-2025-8260?

No fix has been published for CVE-2025-8260 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8260 exists.

## Other vulnerabilities in VaelsysV4

- [CVE-2026-2952](https://insights.sbomify.com/CVE-2026-2952/): Vaelsys HTTP POST Request tree_server.php os command injection (medium 6.9)
- [CVE-2025-8259](https://insights.sbomify.com/CVE-2025-8259/): Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection (medium 6.9)
- [CVE-2025-8261](https://insights.sbomify.com/CVE-2025-8261/): Vaelsys VaelsysV4 User Creation vgrid_server.php improper authorization (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8260 and fix it if it is affected.

What it is: CVE-2025-8260 is a low-severity vulnerability in VaelsysV4, published on 28 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8260 exists.

Affected product: VaelsysV4. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8260/ (Markdown: https://insights.sbomify.com/CVE-2025-8260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8260
- OSV: https://osv.dev/vulnerability/CVE-2025-8260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8260/
Summaries are generated and may contain mistakes; the official description above is the record.
