# CVE-2025-8264: z-push/z-push-dev SQL Injection Vulnerability

> Attackers can inject SQL commands via the username field in basic authentication to access or modify database data in Z-Push IMAP backend installations.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2025
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-w832-w3p8-cw29, UBUNTU-CVE-2025-8264

## What is CVE-2025-8264?

CVE-2025-8264 is a critical SQL injection vulnerability in z-push/z-push-dev, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package z-push/z-push-dev before 2.7.6 are vulnerable to SQL Injection due to unparameterized queries in the IMAP backend. An attacker can inject malicious commands by manipulating the username field in basic authentication. This allows the attacker to access and potentially modify or delete sensitive data from a linked third-party database. **Note:** This vulnerability affects Z-Push installations that utilize the IMAP backend and have the IMAP_FROM_SQL_QUERY option configured.  MitigationChange configuration to use the default or LDAP in backend/imap/config.phpphpdefine('IMAP_DEFAULTFROM', '');orphpdefine('IMAP_DEFAULTFROM', 'ldap');

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-8264?

2 open source packages ship an affected version, including z-push/z-push-dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `z-push/z-push-dev` | Packagist | All versions | 2.7.6 |
| `z-push/z-push-dev` | Packagist | All versions | 2.7.6 |

## How do I fix CVE-2025-8264?

Upgrade z-push/z-push-dev to 2.7.6 or later.

## Is CVE-2025-8264 being exploited?

There is no known exploitation of CVE-2025-8264 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8264 and fix it if it is affected.

What it is: CVE-2025-8264 is a critical SQL injection vulnerability in z-push/z-push-dev, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-8264 in the wild and no public exploit code.

Affected packages and fixed versions:
- z-push/z-push-dev (Packagist): affected all versions; fixed in 2.7.6
- z-push/z-push-dev (Packagist): affected all versions; fixed in 2.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8264/ (Markdown: https://insights.sbomify.com/CVE-2025-8264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8264
- OSV: https://osv.dev/vulnerability/CVE-2025-8264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8264/
Summaries are generated and may contain mistakes; the official description above is the record.
