CVE-2025-8267 ssrfcheck: SSRF Bypass Caused by Failure to Classify Reserved IP Address Space as Invalid

High 8.8 Published Updated

Attackers can bypass SSRF protections in the ssrfcheck library by targeting multicast IP addresses due to an incomplete denylist.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-8267?

CVE-2025-8267 is a high-severity server-side request forgery vulnerability in ssrfcheck, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package ssrfcheck before 1.2.0 are vulnerable to Server-Side Request Forgery (SSRF) due to an incomplete denylist of IP address ranges. Specifically, the package fails to classify the reserved IP address space 224.0.0.0/4 (Multicast) as invalid. This oversight allows attackers to craft requests targeting these multicast addresses.

Weakness: CWE-918

Which versions are affected by CVE-2025-8267?

2 open source packages ship an affected version, including ssrfcheck. It affects 1 product.

PackageAffectedFixed in
ssrfcheck npmAll versions1.2.0
ssrfcheck npmAll versions1.2.0

Products include Felipperegazio Ssrf Check.

How do I fix CVE-2025-8267?

Upgrade ssrfcheck to 1.2.0 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-8267 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8267 exists.

Sources

Also known as GHSA-p4hc-9pjh-55c8.

Is CVE-2025-8267 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free