# CVE-2025-8267: ssrfcheck: SSRF Bypass Caused by Failure to Classify Reserved IP Address Space as Invalid

> Attackers can bypass SSRF protections in the ssrfcheck library by targeting multicast IP addresses due to an incomplete denylist.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-p4hc-9pjh-55c8

## What is CVE-2025-8267?

CVE-2025-8267 is a high-severity server-side request forgery vulnerability in ssrfcheck, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package ssrfcheck before 1.2.0 are vulnerable to Server-Side Request Forgery (SSRF) due to an incomplete denylist of IP address ranges. Specifically, the package fails to classify the reserved IP address space 224.0.0.0/4 (Multicast) as invalid. This oversight allows attackers to craft requests targeting these multicast addresses.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-8267?

2 open source packages ship an affected version, including ssrfcheck. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ssrfcheck` | npm | All versions | 1.2.0 |
| `ssrfcheck` | npm | All versions | 1.2.0 |

Products: Felipperegazio Ssrf Check.

## How do I fix CVE-2025-8267?

Upgrade ssrfcheck to 1.2.0 or later.

## Is CVE-2025-8267 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8267 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8267 and fix it if it is affected.

What it is: CVE-2025-8267 is a high-severity server-side request forgery vulnerability in ssrfcheck, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8267 exists.

Affected packages and fixed versions:
- ssrfcheck (npm): affected all versions; fixed in 1.2.0
- ssrfcheck (npm): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8267/ (Markdown: https://insights.sbomify.com/CVE-2025-8267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8267
- OSV: https://osv.dev/vulnerability/CVE-2025-8267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8267/
Summaries are generated and may contain mistakes; the official description above is the record.
