# CVE-2025-8283: Netavark: podman: netavark may resolve hostnames to unexpected hosts

> Netavark may resolve container hostnames to external servers due to missing search domains, allowing attackers to intercept traffic or access unintended hosts.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2025
- **Updated:** 1 Sep 2026
- **Also known as:** AZL-96981, BELL-CVE-2025-8283, GHSA-rpcf-rmh6-42xr, UBUNTU-CVE-2025-8283

## What is CVE-2025-8283?

CVE-2025-8283 is a low-severity server-side request forgery vulnerability in Redhat Enterprise Linux, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in the netavark package, a network stack for containers used with Podman. Due to dns.podman search domain being removed, netavark may return external servers if a valid A/AAAA record is sent as a response. When creating a container with a given name, this name will be used as the hostname for the container itself, as the podman's search domain is not added anymore the container is using the host's resolv.conf, and the DNS resolver will try to look into the search domains contained on it. If one of the domains contain a name with the same hostname as the running container, the connection will forward to unexpected external servers.

Weakness: CWE-15 (External Control of System or Configuration Setting)

## Which versions are affected by CVE-2025-8283?

2 open source packages ship an affected version, including netavark. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `netavark` | crates.io | All versions | 1.15.1 |
| `netavark` | crates.io | All versions | 1.15.1 |

Products: Redhat Enterprise Linux, Redhat Openshift Container Platform.

## How do I fix CVE-2025-8283?

Upgrade netavark to 1.15.1 or later.

## Is CVE-2025-8283 being exploited?

There is no known exploitation of CVE-2025-8283 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux

- [CVE-2018-14667](https://insights.sbomify.com/CVE-2018-14667/): Red Hat JBoss RichFaces Framework Expression Language Injection (critical 9.8, exploited in the wild)
- [CVE-2021-20325](https://insights.sbomify.com/CVE-2021-20325/): Missing fixes for CVE-2021-40438 and CVE-2021-26691 in the versions of httpd, as shipped in Red Hat Enterprise Linux 8.5.0, causes a securit (critical 9.8)
- [CVE-2018-25011](https://insights.sbomify.com/CVE-2018-25011/): Memory corruption in libwebp (critical 9.8)
- [CVE-2018-25014](https://insights.sbomify.com/CVE-2018-25014/): Other in libwebp (critical 9.8)
- [CVE-2014-3585](https://insights.sbomify.com/CVE-2014-3585/): Supply chain in redhat-upgrade-tool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8283 and fix it if it is affected.

What it is: CVE-2025-8283 is a low-severity server-side request forgery vulnerability in Redhat Enterprise Linux, published on 28 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-8283 in the wild and no public exploit code.

Affected packages and fixed versions:
- netavark (crates.io): affected all versions; fixed in 1.15.1
- netavark (crates.io): affected all versions; fixed in 1.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8283/ (Markdown: https://insights.sbomify.com/CVE-2025-8283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8283
- OSV: https://osv.dev/vulnerability/CVE-2025-8283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8283/
Summaries are generated and may contain mistakes; the official description above is the record.
