CVE-2025-8405 Improper Encoding or Escaping of Output in GitLab

High 7.7 Published Updated

Authenticated users can inject malicious HTML to perform unauthorized actions on behalf of other users in GitLab vulnerability displays.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-8405?

CVE-2025-8405 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated a security issue in GitLab CE/EE affecting all versions from 17.1 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to perform unauthorized actions on behalf of other users by injecting malicious HTML into vulnerability code flow displays.

Weakness: CWE-116

Which versions are affected by CVE-2025-8405?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.1.018.4.6, 18.5.4, 18.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-8405?

Upgrade gitlab to a fixed version for your release line: 18.4.6, 18.5.4 or 18.6.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-8405 being exploited?

There is no known exploitation of CVE-2025-8405 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-8405, GHSA-fjj2-x466-w3hx, UBUNTU-CVE-2025-8405.

Is CVE-2025-8405 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free