{"answers":{"affected":"3 open source packages ship an affected version, including zenml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8406 exists.","fix":"Upgrade zenml to 0.84.2 or later.","what":"CVE-2025-8406 is a medium-severity path traversal vulnerability in zenml-io/zenml, published on 5 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-8406 and fix it if it is affected.\n\nWhat it is: CVE-2025-8406 is a medium-severity path traversal vulnerability in zenml-io/zenml, published on 5 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8406 exists.\n\nAffected packages and fixed versions:\n- zenml (PyPI): affected from 0.81.0; fixed in 0.84.2\n- zenml (PyPI): affected from 0.81.0; fixed in 0.84.2\n- zenml (PyPI): affected from 0.81.0; fixed in 0.84.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8406/ (Markdown: https://insights.sbomify.com/CVE-2025-8406/index.md)","id":"CVE-2025-8406","markdown":"https://insights.sbomify.com/CVE-2025-8406/index.md","name":"CVE-2025-8406","record":{"aliases":["GHSA-q92x-2x5g-h365","PYSEC-2026-2071"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ZenML Python library","requires_auth":"high_privilege","summary":"Attackers can exploit path traversal in ZenML's materializer to overwrite critical files, potentially leading to arbitrary command execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"zenml","vendor":"zenml"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"ZenML version 0.83.1 is affected by a path traversal vulnerability in the `PathMaterializer` class. The `load` function uses `is_path_within_directory` to validate files during `data.tar.gz` extraction, which fails to effectively detect symbolic and hard links. This vulnerability can lead to arbitrary file writes, potentially resulting in arbitrary command execution if critical files are overwritten.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path Traversal in zenml-io/zenml","id":"CVE-2025-8406","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"code-projects Vehicle Management filter2.php sql injection","id":"CVE-2025-8407"},"packages":[{"ecosystem":"PyPI","fixed":["0.84.2"],"introduced":["0.81.0"],"last_affected":[],"package":"zenml","purl":null,"source":"GHSA-q92x-2x5g-h365"},{"ecosystem":"PyPI","fixed":["0.84.2"],"introduced":["0.81.0"],"last_affected":[],"package":"zenml","purl":"pkg:pypi/zenml","source":"GHSA-q92x-2x5g-h365"},{"ecosystem":"PyPI","fixed":["0.84.2"],"introduced":["0.81.0"],"last_affected":[],"package":"zenml","purl":"pkg:pypi/zenml","source":"PYSEC-2026-2071"}],"prev":{"headline":"Improper Encoding or Escaping of Output in GitLab","id":"CVE-2025-8405"},"products":["zenml-io/zenml"],"published":"2025-10-05","related":[{"cvss_score":9.9,"headline":"Directory Traversal in zenml-io/zenml","id":"CVE-2024-2083","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2024-28424","kev_date_added":null,"published":"2024-03-14"},{"cvss_score":8.8,"headline":"ZenML Server Remote Privilege Escalation Vulnerability","id":"CVE-2024-25723","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml","id":"CVE-2024-9340","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":6.5,"headline":"Improper Authorization in zenml-io/zenml","id":"CVE-2024-2035","kev_date_added":null,"published":"2024-06-06"},{"cvss_score":5.4,"headline":"Lack of login attempt rate-limiting in zenml-io/zenml","id":"CVE-2024-4311","kev_date_added":null,"published":"2024-11-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-06","vendors":["zenml-io"]},"summary":"Attackers can exploit path traversal in ZenML's materializer to overwrite critical files, potentially leading to arbitrary command execution.","url":"https://insights.sbomify.com/CVE-2025-8406/"}