# CVE-2025-8406: Path Traversal in zenml-io/zenml

> Attackers can exploit path traversal in ZenML's materializer to overwrite critical files, potentially leading to arbitrary command execution.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-q92x-2x5g-h365, PYSEC-2026-2071

## What is CVE-2025-8406?

CVE-2025-8406 is a medium-severity path traversal vulnerability in zenml-io/zenml, published on 5 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

ZenML version 0.83.1 is affected by a path traversal vulnerability in the `PathMaterializer` class. The `load` function uses `is_path_within_directory` to validate files during `data.tar.gz` extraction, which fails to effectively detect symbolic and hard links. This vulnerability can lead to arbitrary file writes, potentially resulting in arbitrary command execution if critical files are overwritten.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-8406?

3 open source packages ship an affected version, including zenml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zenml` | PyPI | From 0.81.0 | 0.84.2 |
| `zenml` | PyPI | From 0.81.0 | 0.84.2 |
| `zenml` | PyPI | From 0.81.0 | 0.84.2 |

Products: Zenml Zenml.

## How do I fix CVE-2025-8406?

Upgrade zenml to 0.84.2 or later.

## Is CVE-2025-8406 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8406 exists.

## Other vulnerabilities in zenml-io/zenml

- [CVE-2024-2083](https://insights.sbomify.com/CVE-2024-2083/): Directory Traversal in zenml-io/zenml (critical 9.9)
- [CVE-2024-28424](https://insights.sbomify.com/CVE-2024-28424/): Code injection in n/a (high 8.8)
- [CVE-2024-25723](https://insights.sbomify.com/CVE-2024-25723/): ZenML Server Remote Privilege Escalation Vulnerability (high 8.8)
- [CVE-2024-9340](https://insights.sbomify.com/CVE-2024-9340/): Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml (high 7.5)
- [CVE-2024-2035](https://insights.sbomify.com/CVE-2024-2035/): Improper Authorization in zenml-io/zenml (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8406 and fix it if it is affected.

What it is: CVE-2025-8406 is a medium-severity path traversal vulnerability in zenml-io/zenml, published on 5 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8406 exists.

Affected packages and fixed versions:
- zenml (PyPI): affected from 0.81.0; fixed in 0.84.2
- zenml (PyPI): affected from 0.81.0; fixed in 0.84.2
- zenml (PyPI): affected from 0.81.0; fixed in 0.84.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8406/ (Markdown: https://insights.sbomify.com/CVE-2025-8406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8406
- OSV: https://osv.dev/vulnerability/CVE-2025-8406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8406/
Summaries are generated and may contain mistakes; the official description above is the record.
