# CVE-2025-8521: givanz Vvveb Add Type post-types cross site scripting

> Remote attackers can inject malicious scripts via the Add Type handler in Vvveb, potentially leading to code execution or account takeover.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-6vjh-hc78-5v2f

## What is CVE-2025-8521?

CVE-2025-8521 is a medium-severity cross-site scripting vulnerability in givanz Vvveb, published on 4 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in givanz Vvveb up to 1.0.5. This issue affects some unknown processing of the file /vadmin123/index.php?module=settings/post-types of the component Add Type Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.6 is able to address this issue. The patch is named b53c7161da606f512b7efcb392d6ffc708688d49/605a70f8729e4d44ebe272671cb1e43e3d6ae014. It is recommended to upgrade the affected component.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-8521?

It affects 1 product.


Products: Vvveb Vvveb.

## How do I fix CVE-2025-8521?

No fix has been published for CVE-2025-8521 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8521 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8521 exists.

## Other vulnerabilities in givanz Vvveb

- [CVE-2025-44022](https://insights.sbomify.com/CVE-2025-44022/): Code injection in n/a (critical 9.8)
- [CVE-2025-11028](https://insights.sbomify.com/CVE-2025-11028/): givanz Vvveb Image information disclosure (medium 6.9)
- [CVE-2025-12203](https://insights.sbomify.com/CVE-2025-12203/): givanz Vvveb Code Editor functions.php sanitizeFileName path traversal (medium 5.3)
- [CVE-2025-11029](https://insights.sbomify.com/CVE-2025-11029/): givanz Vvveb cross-site request forgery (medium 5.3)
- [CVE-2025-9728](https://insights.sbomify.com/CVE-2025-9728/): givanz Vvveb login.tpl cross site scripting (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8521 and fix it if it is affected.

What it is: CVE-2025-8521 is a medium-severity cross-site scripting vulnerability in givanz Vvveb, published on 4 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8521 exists.

Affected product: givanz Vvveb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8521/ (Markdown: https://insights.sbomify.com/CVE-2025-8521/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8521
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8521
- OSV: https://osv.dev/vulnerability/CVE-2025-8521

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8521/
Summaries are generated and may contain mistakes; the official description above is the record.
